Jump to content

ssblast20

Members
  • Posts

    29
  • Joined

  • Last visited

Everything posted by ssblast20

  1. Hi Jay, I have excellent clean OEM gas tanks in stock. Shoot me a message if you’d like to discuss, or you can text/call me as well. Steve 540-379-8nine5won
  2. Hi there, and welcome to the group! Very cool that you have gotten your hands on one, they are awesome cars and becoming rarer as time goes on, but this is a great group of individuals to help you in your journey! I run one of the main OEM parts website at www.starquestparts.net, and there are some other resources on the bottom of my homepage with links to other providers as well like MKS motorsports, DAD’s, Motocam etc. I also welcome phone calls, and or texts with any questions on things that I can help with that I’m knowledgeable about, and you can also post here and you will get some great advice from you guys have been in the game for decades. Best of luck with getting her fixed up! -Steve
  3. I would say maybe 3 feet long for when you are loading on the ramps, and then just a couple 1 foot sections for the front. I’ve towed probably 20 of these things, and I’ve used a U-Haul trailer every time. It’s just a close call and you’ll want that a little bit of leverage, just to be safe.
  4. Use them all the time. Just carry a couple cut 2x6s and you’ll be fine loading. Then a couple small 2x6s (about 12” length) to put under the front wheels once you load it. Steve
  5. I have seen this happen before… Most likely the front struts needed to be replaced, and they simply swapped over a good set from another car that happened to be the SHP’s. That’s really the only logical explanation and like I said, I’ve seen it in the front, and I l,ve also seen it also in the rear independently. Nothing wrong or bad about it per se, but definitely not something that was done from the factory for any reason. Steve
  6. Nice find! Enjoy the journey…these are head turners and fun cars once you get things sorted out. If / when you need parts, see my website at www.StarquestParts.net which I update regularly. There are links to other reputable vendors on my home page as well. Welcome to the SQ Club!! -Steve
  7. Sounds good….I’ve shipped them quite often. Not as bad to ship as you might think, probably around $75 or so for both. Or much less for just a tube and mating gear. Steve
  8. 88/89 diff and axles are unique, and you cannot for 87 axles into an 88/89 diff and vice versa. However, the torque tubes are interchangeable between years. I have a couple spares in my stash for sale (diffs and tubes) if other options fall through. Steve
  9. None of those websites that show direct Japan inventory are legit - they will all contact you weeks later saying “out of stock”. Send yours off to be rebuilt or buy a core unit to have rebuilt. You can send it to these guys https://www.straightlinesteering.com -Steve
  10. Good evening, I have a couple good stock turbos in stock, and I also have the vacuum advance if you never found one. If you have any questions, just let me know. Thanks, Steve www.Starquestparts.net
  11. Very few widebodies came with that package, 86 and a few 87 only and in very limited numbers. And many people actually had issues with the digital clusters, so as cool as they were, they were not very dependable with no real ability to service them as the years went on. I do agree with the cool factor though. Steve
  12. @nc_beagle I’ve got a couple that I’ll be selling soon just north of you in VA if you’d like some info. I’ll send you a private message.
  13. Most of those websites show all the diagrams etc but never have those items in stock. They’ve been disappointing people for years but still show everything as available. I should have a couple of them…send me message if you’d like. -Steve
  14. I have them - shoot me a message if you’d like. Steve
  15. Should cost you about 150 to have that fixed...should not be a problem.
  16. I have to ask…did I pass you on the road going through Orange VA a couple days ago???
  17. Regarding the diplay, find the proper fuse in the fuse panel and wiggle it and see if that does anything. It's common for the terminals that hold the fuse to widen, so you can bend them back with an eyeglass flathead to tighten them up again. If not, you may have a bad display. Are you talking about the fog light in the front bumper? Or the headlight itself? Steve
  18. I've got a low mileage mint one, and a couple others...feel free to text or call if you'd like at 540-379-8951 -Steve
  19. @K_Schutte I messaged you on Facebook - check your "message requests" - I'll private message you on here as well. -Steve
×
×
  • Create New...