Jump to content
  • Welcome (back) to StarQuestClub!

    OH NO!!!

    The data center where the site was housed on a Virtual Machine was shut down. The person who was in charge of the VM never saw the emails about migrating because it was flagged as spam and went to his junk folder. Long story short, they turned off the lights and locked the door without SQC being migrated to a new server.


    Unfortunately the most viable backup to use is from Nov. 2015 so we lost numerous posts and registered members. If you joined after that date you will need to register again.


    The new site requires you to use the email address in your profile to log into SQC and whatever password you had back in 2015. If you don’t remember your password there is a “Forgot your password?” option at the bottom of the Sign In block. If you don’t remember the email you used in your profile contact one of the Moderators for assistance or email loginhelp@starquestclub.com 

    Various parts in PA

    bld127
    By bld127,
    After like 28 years of messing with these cars I have decided to move on.  I have sold 2 of my cars, most of my parts, and the parts car is going to the scrapyard soon.  Cleaned out the shed and garage and these are the parts that I still have left.     Starion "TURBO" rear hatch, painted yellow, no struts - $75 Hood, paint is peeling, some minor dents and a little surface rust - $50 87 and earlier maroon velour Passenger side seat in good shape (also have an extra set of con

    Factory Radio Wiring

    BlueCuda
    By BlueCuda,
    Does the factory radio harness have a "sub harness" that goes from the radio perhaps to an amp or something then plug in?  Or does it go the distance to the speakers etc? My good 87 has radio wiring that has been partially cut off, my parts car has a stock radio so I am hoping the wiring behind it hasn't been touched.  I would love to be able to just unplug bad wiring and plug good wiring in if possible.  Before my parts car I bought stock radio connectors with about 12" of wire that I can

    Fuel pump running, but no fuel pressure

    Helterbot
    By Helterbot,
    I'm trying to get my car started after being down for 4 years, but I'm not seeing at  fuel at the throttle body. I used the jumper on the passenger side engine compartment to test the fuel pump, and you can definitely hear it running. I removed the fuel filter and put the fuel line into a bucket and powered the pump for a minute, but nothing ever came out. What would cause this to not work? Is it likely that something is clogged? The tank is full of non-oxy gas that had Stabil in it, so I'm

    Aftermarket Camshaft Camcard Info

    kev
    By kev,
    I found this in my files.  It shows the cam info for many of the aftermarket camshaft options that were available awhile back.   I did not create this file, I simply took a screenshot of it on here years ago.    So take it with a grain of salt, but I thought it may be useful to some.    

Portal by DevFuse · Based on IP.Board Portal by IPS
×
×
  • Create New...