Jump to content

ABS light on after LED swap


Recommended Posts

Putting this in AVM since this is modification-related, let me know if I got the wrong forum.

So, some time back, I went the way of the LED with my taillights and my front turn signals. Also swapped out my hazard and turn signal flashers with no-load flashers so they would actually work. Not long after I did this, my ABS light came on and has been on ever since. I remember reading in a thread (that I can't find anymore) that the ABS computer will throw a fault if something is really off about the brake light circuit. I reviewed the wiring diagram, and I see this B-12 resistor inline just after the brake switch.
Has anyone here who's swapped out the brake/taillight bulbs out with LEDs kept their ABS? What needs to be done to the brake lock-up circuit? Is it as simple as replacing this with a higher-ohm resistor?:
AFqMNwY.png

I know I could just delete the ABS, but I'm kinda trying to keep things original for the moment, and I'd hate to toss out an otherwise functional ABS system. Any help is appreciated.

Link to comment
Share on other sites

I didn't need to do anything when I swapped in LED's.

I had my ABS light on before the swap, however, when I took apart the abs solenoids and cleaned out/regreased them, the light went off.

Link to comment
Share on other sites

21 hours ago, tux said:

I didn't need to do anything when I swapped in LED's.

I had my ABS light on before the swap, however, when I took apart the abs solenoids and cleaned out/regreased them, the light went off.

Yeah I was kinda afraid it might have been convenient timing. The brake fluid does look old, I'll try flushing it to see if that helps. If it comes down to it, how difficult is it to regrease those solenoids? Didn't immediately see a write up on it.

Link to comment
Share on other sites

It's pretty easy

The solenoids are those wonky things sticking off the top.  I just removed them, disassembled,  cleaned the hardened grease out with brake cleaner, added new grease and reassembled.

s-l300.jpg

Link to comment
Share on other sites

 Share

×
×
  • Create New...