Jump to content



Secondary injector


  • Please log in to reply
15 replies to this topic

#1 lvmx742

lvmx742

    Member

  • Members
  • PipPipPip
  • 81 posts
  • Location:baltimore,md.

Posted 24 July 2018 - 04:23 AM

My quest is falling on its face when I give it gas it idles fine and will rev if I give it gas easy. I checked vac. advance it holds vac I tested and set TPS. There is power going the the new secondary injector clip.is there a way to test the injector to see if it is firing or just leaking or clogged.





#2 croquest87

croquest87

    Established Member

  • Members
  • PipPipPip
  • 1,221 posts
  • Gender:Male
  • Location:willoughby
  • Interests:all things mechanical
  • Model:Conquest

Posted 24 July 2018 - 05:28 AM

Start the car and shut it off.Get a flashlight. Leave your key in on position.
Take off your ovcp and look inside the throttle body see if any drips out of injectors. For best results send your injectors out for cleaning and testing rock auto does it as well as other places.Also fuel gage should be installed at the back of tb  where the set screw is.Fuel pressure should stay at 36-38 and never drop regardless of rpms.If it does? Your fuel filters are clogged most likely from rusty tank or your fuel pump is weak possible fpr. But most likely clogged fuel filters. In that case l suggest cleaning the fuel tank new filters and cleaning all the lines top hat before you install your new or tested injectors.Little bid of work but worth it!

Other things to do is check your timing is set at 10deg and test your vacum advance.New plugs wires cap rotor and ignition coil.
Good luck
Dra

Edited by croquest87, 24 July 2018 - 05:35 AM.


#3 lvmx742

lvmx742

    Member

  • Members
  • PipPipPip
  • 81 posts
  • Location:baltimore,md.

Posted 25 July 2018 - 07:08 PM

Ok I didn't see any drips coming from either injector. I can hear a pluse coming from the primary injector but I don't hear a pluse coming from the secondary injector I hear a faint pulse but I think that I,m hearing the primary pulse.so I'm thinking the secondary injector is not working I assume the coil is not working.

#4 lvmx742

lvmx742

    Member

  • Members
  • PipPipPip
  • 81 posts
  • Location:baltimore,md.

Posted 25 July 2018 - 07:11 PM

It's weird to me though I never had a problem with the car falling on its face until I rebuilt the throttle body but I think it's my injector.

#5 croquest87

croquest87

    Established Member

  • Members
  • PipPipPip
  • 1,221 posts
  • Gender:Male
  • Location:willoughby
  • Interests:all things mechanical
  • Model:Conquest

Posted 25 July 2018 - 08:36 PM

If your car is 87-89  secondary injector does not kick in until 2500 rpms or so  and you will not hear it! They are not leakin and that's good. Could be not spraying right though.  Just to eliminate it  check your compression and post your readings here! When checking compression unplug your injectors disconnect your ign coil remove plugs and check one hole at the time.  Car in neutral parking brake on be safe! After l see your numbers we can go after the fuel press testing. In mean time send your injectors to be clean and tested for operation don't guess things know!

Edited by croquest87, 25 July 2018 - 08:46 PM.


#6 lvmx742

lvmx742

    Member

  • Members
  • PipPipPip
  • 81 posts
  • Location:baltimore,md.

Posted 01 August 2018 - 05:27 PM

I think I found the problem with my car falling on its face when giving it gas. I traced my vacuum hoses the ones going to the thermo valve was not holding vacuum I pulled the first hose off and tested the hose for leak's it held I went to pull the second hose off and the nipple broke off when I pulled the hose off the nipple came off with it I'm assuming the nipple was cracked. So is this a part I can buy I looked on rock auto and didn't see anything.

#7 croquest87

croquest87

    Established Member

  • Members
  • PipPipPip
  • 1,221 posts
  • Gender:Male
  • Location:willoughby
  • Interests:all things mechanical
  • Model:Conquest

Posted 01 August 2018 - 08:22 PM

I had a hard time finding one  bought used one.  If you don't need to pass smog test just eliminate all that environmental nonsense lol

#8 lvmx742

lvmx742

    Member

  • Members
  • PipPipPip
  • 81 posts
  • Location:baltimore,md.

Posted 02 August 2018 - 05:24 AM

I found one on here. I don't need to pass smog I have the car tagged historic. Is the thermo valve part of the smog stuff. Can I just cap or plug those vacuum hoses that goes to the thermo valve?

#9 croquest87

croquest87

    Established Member

  • Members
  • PipPipPip
  • 1,221 posts
  • Gender:Male
  • Location:willoughby
  • Interests:all things mechanical
  • Model:Conquest

Posted 02 August 2018 - 07:48 AM

Thermo valve evacuatesfumes from your gas tank Thermo valve opens up when car reaches normal operating temperature those fumes are sent do the intake into the engine to get burned off you can remove all that all you have to do is remove everything from the vacuum lines check valves charcoal filter even the metal line if you like all the way to the bank and just put a small hose on there which simple one way check valve so that your tank can breath are in and nothing can come back out I put the check valve right where the filler cap is area

#10 lvmx742

lvmx742

    Member

  • Members
  • PipPipPip
  • 81 posts
  • Location:baltimore,md.

Posted 08 August 2018 - 07:26 AM

My car is still falling on its face I tested my second injector again it doesn't seem to be working I switched injectors I out the second injector where the primary injector goes the car would only crank but wouldn't start I switched them back and the car runs. What is my options when it comes to getting injectors staying with the stock injectors which is what I'd like to do or should I just go with the aftermarket injectors.

#11 croquest87

croquest87

    Established Member

  • Members
  • PipPipPip
  • 1,221 posts
  • Gender:Male
  • Location:willoughby
  • Interests:all things mechanical
  • Model:Conquest

Posted 08 August 2018 - 10:54 AM

Send them to get cleaned and tested. Stock injectors work best on these cars! I have a set of trilogy and fuel injector clinic injectors and have run both. They work ok but nothing works like stockers. If your stockers turn out to be bad when they clean them. Look for used once on here someone will hook you up for best results. I find it that aftermarket injectors need Maft or some kind of standalone ecu to be able to adjust your afr because of spray pattern and fuel doesn't get atomized like with stock injectors.

Edited by croquest87, 08 August 2018 - 10:55 AM.


#12 madmanperez

madmanperez

    Member

  • Members
  • PipPipPip
  • 79 posts
  • Gender:Male
  • Location:Central Florida
  • Model:Starion

Posted 08 August 2018 - 01:37 PM

http://fuelinjectorc...StarionConquest

I bought a pair of injectors (primary and secondary) $225 ($240 after tax and shipping) They do sell a highflow secondary but its not stock. Warranted for life, can't beat that. They're in Tampa FL. I'm in Central FL. so I got the m next day with regular shipping.

Hope that helps

correction: just checked the website and they list the warranty as 12 months

Edited by madmanperez, 08 August 2018 - 01:42 PM.


#13 lvmx742

lvmx742

    Member

  • Members
  • PipPipPip
  • 81 posts
  • Location:baltimore,md.

Posted 09 August 2018 - 07:30 AM

It's fixed for now I took my injector out and cleaned it really good and filed and cleaned the 2prongs on the injector really good also put it back in and it runs good with no hesitation.

#14 croquest87

croquest87

    Established Member

  • Members
  • PipPipPip
  • 1,221 posts
  • Gender:Male
  • Location:willoughby
  • Interests:all things mechanical
  • Model:Conquest

Posted 09 August 2018 - 07:40 AM

Glad you fixed it.

#15 Contsis

Contsis

    Member

  • Members
  • PipPipPip
  • 195 posts
  • Gender:Male
  • Location:MA
  • Model:Conquest

Posted 09 August 2018 - 11:51 AM

View Postmadmanperez, on 08 August 2018 - 01:37 PM, said:

http://fuelinjectorc...StarionConquest

I bought a pair of injectors (primary and secondary) $225 ($240 after tax and shipping) They do sell a highflow secondary but its not stock. Warranted for life, can't beat that. They're in Tampa FL. I'm in Central FL. so I got the m next day with regular shipping.

Hope that helps

correction: just checked the website and they list the warranty as 12 months

I love the stock injectors - had one replaced with used - still good.
How do you like these? How is the fitment with the spacers? does the stock pigtail fit?

#16 madmanperez

madmanperez

    Member

  • Members
  • PipPipPip
  • 79 posts
  • Gender:Male
  • Location:Central Florida
  • Model:Starion

Posted 02 September 2018 - 02:28 PM

Contsis:

Fitment with the spacers was fine, since these have angled connectors (that why the spacers). Everything hooked fine, Nice and tight.

The stock(?) pigtails are standard GM plugs (at least on mine) Car was falling on its face under boost (anything over 3k-3.5k unless you slowly accelerate)

After I put in the pair it's been running fine, pulls nice and boosts good. Boost buids up at about 2.5k-3k and goes up from there under load.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users