Jump to content



86 Fuel Injectors?


  • Please log in to reply
5 replies to this topic

#1 Chuck86TSI

Chuck86TSI

    Newbie

  • Newbies
  • PipPipPip
  • 4 posts
  • Gender:Male
  • Location:Delaware
  • Model:Conquest

Posted 21 May 2020 - 08:44 PM

Ok.  I am 100 percent sure these are not the factory injectors for my 86 Conquest. Started to figure that out when the spacers fell out when I lifted off the top hat.  That said, does anyone know anything about these and how they are in the stock TB.  I thought only stockers fit unless the TB was machined out.  Does that mean my throttle body has been modified for these to fit in?  Seams like the original “bottom” seals (I got a new seal kit from DAD) fits snug in the TB.

One has a “W” and “X” on it and the other has a “W”and an “R”. Cant tell what the logo is.  Appears to be RP? I believe everything I read on the 86 is both injectors should be the same. But these must be different? Anyone know what this set up is? Purchased the car over the winter and slowly have got it running better, but still seems to be running very rich and stumbles badly at lower rpms and periodically when cruising down the road at speed(65). Plus exhaust fumes are very strong!  Hit the gas hard and clears up on the road. Was originally thinking the factory injectors might need to be cleaned so I was pulling them off to take to a local shop that cleans and flow tests them.   Not sure what to do at this point.  Any thoughts or insight?  Appreciate any help or info you guys can give!

Attached Files







#2 markhansenconquest

markhansenconquest

    Established Member

  • Members
  • PipPipPip
  • 3,696 posts
  • Gender:Male
  • Location:temecula,ca
  • Model:Conquest

Posted 21 May 2020 - 09:05 PM

those are Delphi aftermarket injectors usualy they grind 850 cc on side of them for 86 and 650 cc and 950 cc for 87-89 ……..best to look for stock 86 ones like a J OR H stock 850 cc injectors work best with a stock system...A ll the gas fumes are the injectors seals are leaking and your TBI needs a rebuield too... ...U need to rebuild the whole TBI  before U  have a fire !!!!  while u are there u need to replace all 3 filters  tooo……..eng bay, top hat screens ,befrore pump(,CONE FILTER IN LINE ) screen in tank....if u drain gas out with drain plug u will see how much rust and dirt comes out u must have fuel system totally clean so u know your fuel is a steady flow with both injectors ….if the flow is not steady u will never get it to run right.....

Edited by markhansenconquest, 21 May 2020 - 09:29 PM.


#3 Chuck86TSI

Chuck86TSI

    Newbie

  • Newbies
  • PipPipPip
  • 4 posts
  • Gender:Male
  • Location:Delaware
  • Model:Conquest

Posted 21 May 2020 - 09:11 PM

So my stock throttle body and top hat should be good to put stockers back in?  I was concerned they might have been machined out.  The one injector was really wedged in the throttle body. Was very hard to get it out.

#4 pcristquester

pcristquester

    Established Member

  • Members
  • PipPipPip
  • 2,533 posts
  • Gender:Male
  • Location:Lakeside, CA
  • Interests:Family, fishing, Starquests and other unique cars. IPA and IIPA
  • Model:Conquest

Posted 21 May 2020 - 10:27 PM

Yes, but good luck finding good 86 OEM injectors
Posted Image

#5 Chuck86TSI

Chuck86TSI

    Newbie

  • Newbies
  • PipPipPip
  • 4 posts
  • Gender:Male
  • Location:Delaware
  • Model:Conquest

Posted 22 May 2020 - 09:11 AM

Yeah.  I know.   So the search begins!!!!!  If anyone has a good set hit me up please!!!!

#6 aknorthstar

aknorthstar

    FarNorth Member

  • Members
  • PipPipPip
  • 1,462 posts
  • Gender:Male
  • Location:Alaska
  • Model:Starion

Posted 22 May 2020 - 12:41 PM

I could never get my 86 to run right with the 850cc Delphi injectors, It did run good with 2 950cc Delphi injectors. I eventually found a set of stock 86 injectors had them cleaned and the car runs perfect. Good Luck!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users