Jump to content



Brakes not working


  • Please log in to reply
7 replies to this topic

#1 StarquestRescue

StarquestRescue

    Established Member

  • Members
  • PipPipPip
  • 4,592 posts
  • Gender:Male
  • Location:Lancaster PA
  • Interests:Mits owner from 1980
  • Model:Conquest

Posted 22 July 2017 - 12:56 PM

Car sat 7 years. At first pedal was hard as a rock very little whoa. Changed calipers from a car that was wreaked a year ago. Now has normal peddle feel but no more whoa. Thought maybe the rotors were just to rusty, so installed front rotors and matching pads from the doner car.

No improvement in stopping power.

  If I coast down a hill, shut the motor off and pump the brake to bleed off the vacuum to the brake booster. And then restart the car the brake pedal feels like the booster kicks in but no change in stopping power.

The ebrake works better then the service brakes!  After a short drive and using the ebrake some. Rear rotor temps were 220, front 160.


What next?

Edited by StarquestRescue, 22 July 2017 - 12:57 PM.

2012 fall set up 20g 06  in the stock turbine houseing. 2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  379hp 395 tq TBI Power

2012 spring set up. 18g06 in the stock turbine houseing.  2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  Innovated data logging. 358 hp 393 tq. 12.71 @ 112
2011 set up. 18g05h,  2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  Innovated data logging. 307 hp 360 tq  12.78 @ 112
2010 set up. 18g05h,  2G mas, Lsp 850 / 1400 injectors. Tuned with re flashed afc Neo version 1.104 and Innovated data logging.  297 hp 403 tq.


401 / 427 TBI   Dyno link-----------TBI Power http://www.sqperform....php?topic=33.0-----------Rear Gear link----------2010 Dyno link-------Feedback link





#2 ucw458

ucw458

    This will mean the extinction of all life forms on this planet.

  • Moderators
  • PipPipPipPipPip
  • 11,342 posts
  • Gender:Male
  • Location:Colorado
  • Model:Conquest

Posted 22 July 2017 - 01:26 PM

Master cyl, it's the one part that has failed on every SQ I've owned.  There's also a rear brake bias valve below the booster that has clogged on a few members cars causing brake issues.
My 87
Posted Image

#3 StarquestRescue

StarquestRescue

    Established Member

  • Members
  • PipPipPip
  • 4,592 posts
  • Gender:Male
  • Location:Lancaster PA
  • Interests:Mits owner from 1980
  • Model:Conquest

Posted 22 July 2017 - 01:35 PM

But it pushes the pistons out just fine if I have then pushed in and the caliper's bleed ok, so it is moving fluid?
2012 fall set up 20g 06  in the stock turbine houseing. 2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  379hp 395 tq TBI Power

2012 spring set up. 18g06 in the stock turbine houseing.  2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  Innovated data logging. 358 hp 393 tq. 12.71 @ 112
2011 set up. 18g05h,  2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  Innovated data logging. 307 hp 360 tq  12.78 @ 112
2010 set up. 18g05h,  2G mas, Lsp 850 / 1400 injectors. Tuned with re flashed afc Neo version 1.104 and Innovated data logging.  297 hp 403 tq.


401 / 427 TBI   Dyno link-----------TBI Power http://www.sqperform....php?topic=33.0-----------Rear Gear link----------2010 Dyno link-------Feedback link

#4 87redcat

87redcat

    9 years and counting...

  • Members
  • PipPipPip
  • 3,510 posts
  • Gender:Male
  • Location:Maryville, TN
  • Interests:Aircraft Mechanic, working on the new house while dust collects on my wife's quest and on my quest
  • Model:Conquest

Posted 22 July 2017 - 02:08 PM

Rear brake valve like ucw said or still air in a line somewhere or master getting ready to let go. My brakes were fine one day, then went to the floor the next. No amount of pumping the pedal helped. Master was leaking into the booster
I got blisters on my fingers!!!

#5 tsi_tom

tsi_tom

    Established Member

  • Members
  • PipPipPip
  • 2,054 posts
  • Gender:Male
  • Location:Quakertown, Pennsylvania
  • Model:Conquest

Posted 22 July 2017 - 02:53 PM

I think I have this problem too.  It seems like I have to press the pedal too hard to stop.
Engine
20 over forged pistons
Stock injection system

My restoration project: The Missouri Project

#6 ucw458

ucw458

    This will mean the extinction of all life forms on this planet.

  • Moderators
  • PipPipPipPipPip
  • 11,342 posts
  • Gender:Male
  • Location:Colorado
  • Model:Conquest

Posted 22 July 2017 - 02:58 PM

With any damaged pump you can have it flow but never build pressure.  With the bleeders open there's no resistance so you get flow.  But with the bleeders closed the resistance can cause the fluid to flow past leaky pistons back into the resivour.  Or leak out the back into the booster.
My 87
Posted Image

#7 87redcat

87redcat

    9 years and counting...

  • Members
  • PipPipPip
  • 3,510 posts
  • Gender:Male
  • Location:Maryville, TN
  • Interests:Aircraft Mechanic, working on the new house while dust collects on my wife's quest and on my quest
  • Model:Conquest

Posted 23 July 2017 - 08:52 PM

BINGO!!!
I got blisters on my fingers!!!

#8 StarquestRescue

StarquestRescue

    Established Member

  • Members
  • PipPipPip
  • 4,592 posts
  • Gender:Male
  • Location:Lancaster PA
  • Interests:Mits owner from 1980
  • Model:Conquest

Posted 23 July 2017 - 09:50 PM

I am thinking purporting valve or abs modulator. If the master cylinder was leaking the pedal would drift towards the floor. It does not.
2012 fall set up 20g 06  in the stock turbine houseing. 2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  379hp 395 tq TBI Power

2012 spring set up. 18g06 in the stock turbine houseing.  2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  Innovated data logging. 358 hp 393 tq. 12.71 @ 112
2011 set up. 18g05h,  2g mas, Neo afc, Versafueler, 1050 / 2000 injectors on E85.  Innovated data logging. 307 hp 360 tq  12.78 @ 112
2010 set up. 18g05h,  2G mas, Lsp 850 / 1400 injectors. Tuned with re flashed afc Neo version 1.104 and Innovated data logging.  297 hp 403 tq.


401 / 427 TBI   Dyno link-----------TBI Power http://www.sqperform....php?topic=33.0-----------Rear Gear link----------2010 Dyno link-------Feedback link




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users