Jump to content



Recently bought 88 conquest with t3t4 turbo not spooling. Dies if you give it more than 1/4 throttle. Told by many experts it's not computer related.

turbo not boosting

  • Please log in to reply
12 replies to this topic

#1 Rob D

Rob D

    Newbie

  • Newbies
  • Pip
  • 6 posts
  • Location:Groton

Posted 08 October 2016 - 01:07 AM

Replaced both injectors. No improvement. I've had the car for one day, been in shop for six weeks. Any help would be greatly appreciated.
Thank you.
Rob.





#2 speedyquest

speedyquest

    Established Member

  • Members
  • PipPipPip
  • 3,890 posts
  • Gender:Male
  • Location:La Crosse Wisconsin
  • Interests:bmx, cars, computers
  • Model:Starion

Posted 08 October 2016 - 01:18 AM

That simply isn't enough information. Can you describe the setup, the cars history, and a more specific description of what the car is doing?

1987 Flatty Starion -- Widebody Conversion -- V-Mount Setup --  JDL Tubular Manifold  --  MX-6 Intake -- MS3-Pro -- AEM FPR  --  ARP head studs -- 3" hood exit exhaust -- Hahn Racecraft 16g --  Tial F38 Wastegate -- Tial Q Bov -- Short route piping -- 5 lug & LSD conversion -- Tubular Front End -- Manual Steering Rack Conversion -- Manual Brake Conversion -- Stack Digital Dash -- AEM UEGO -- D2 coilovers -- full GNT poly bushings & mounts -- four 8" rears -- car lightened significantly...  More to come!


Posted Image


Build Thread --->  http://www.starquest...opic=143564&hl=


#3 vbrad511

vbrad511

    Advanced Member

  • Members
  • PipPipPipPip
  • 8,314 posts
  • Location:springfield, illinois
  • Interests:Keep the turbo spooled!

Posted 08 October 2016 - 08:47 AM

You won't find experts anywhere like you'll find here. These cars are their own breed when it comes to the fuel and ignition systems. Even when they were new many dealerships didn't have the tech guys to work on them. The past few decades the folks here have discovered more than most Mitsu mechanics ever knew about them. Fill us in on the car and somebody'll help.

#4 chassispuke

chassispuke

    Established Member

  • Members
  • PipPipPip
  • 737 posts
  • Gender:Male
  • Location:s.cali
  • Model:Conquest

Posted 08 October 2016 - 09:15 AM

Sounds more like TPS has a dead spot or ISC motor is going out

#5 rcm

rcm

    rcm

  • Members
  • PipPipPip
  • 2,075 posts
  • Gender:Male
  • Location:Bluff Dale Texas
  • Interests:Keep the turbo spooled!
    Motorcycles,dirt bikes,Old school
    muscle cars.
  • Model:Conquest

Posted 08 October 2016 - 09:26 AM

So many things to check.Fuel pressure for one.The fuel pump may be toast.Do need more info.

#6 importwarrior

importwarrior

    6 Quests and Counting......

  • Moderators
  • PipPipPipPipPip
  • 18,071 posts
  • Gender:Male
  • Location:Manassas VA
  • Interests:Boost = 2KWIK4U
    Starquests
  • Model:Conquest

Posted 08 October 2016 - 06:14 PM

1st make sure the MAF sensor plug is connected...
if you can swap it for a know working good one

B-71 87 TSI ~ RIP

Black 87 Starion ~ Mess SOLD!!!

Proud New 89 slightly Rusted Fiji Owner !!!




#7 Zoggy87

Zoggy87

    Member

  • Members
  • PipPip
  • 387 posts
  • Location:USA

Posted 09 October 2016 - 09:17 AM

These cars absolutely run like dog s*** if the maf is even a little off. Do as suggested above and test that you have a good maf. First thing I would honestly suggest doing is make absolutely positive there are no air leaks both compressor side of maf as well as entire pressure side. Air leak between maf and compressor will give severe lean condition, and leak anywhere on pressure side will give rich conditions. An a/f gauge and wideband makes troubleshooting performance issues much easier/efficient.

#8 Zoggy87

Zoggy87

    Member

  • Members
  • PipPip
  • 387 posts
  • Location:USA

Posted 09 October 2016 - 09:20 AM

Just for clarification.... By not spooling, do you mean to say it's not turning?

#9 Rob D

Rob D

    Newbie

  • Newbies
  • Pip
  • 6 posts
  • Location:Groton

Posted 15 October 2016 - 01:20 AM

Turbo is spooling to the moon (allegedly) is what the speed shop told me. If I give it more than a 1/4 throttle she dies. The speed shop where the car is specializes in Hondas, says it is computer related. Every Mitsubishi specialist has insisted not computer related.
Thank you for your response

#10 Rob D

Rob D

    Newbie

  • Newbies
  • Pip
  • 6 posts
  • Location:Groton

Posted 15 October 2016 - 01:42 AM

Don't know much about the history. The person I bought the car from was the second owner. He did most of the mods.(car ran fine with mods, sat for two months, current results,he alleges 20 boost no problem). 2nd owner has nothing to lose I told him I didn't care about any problems that I would take care of them. He has been as helpful as I think he can, but he is also at a loss. Talked to the people who sold the t3t4 set up, they said it is good to go without touching the computer. I wish I knew more about this stuff because I truly love these cars. (Was my first new car at age 18, 88 left over. Nothing but regrets after trading it in)
Thanks again guys.
Rob.

#11 importwarrior

importwarrior

    6 Quests and Counting......

  • Moderators
  • PipPipPipPipPip
  • 18,071 posts
  • Gender:Male
  • Location:Manassas VA
  • Interests:Boost = 2KWIK4U
    Starquests
  • Model:Conquest

Posted 16 October 2016 - 05:27 PM

where is Groton? maybe someone near can help.

if your CAT is clogged = No Boost maybe 4 PSI with clogged CAT converter
remove it try again

if no way to tune the car Example : MAF Translator or some other device then dont kill your engine

get one if you have one then start tuning from the beginning again or get it tuned.

if the tune is not right an excess amount of air going through the MAF will cause it to act like fuel cut.

B-71 87 TSI ~ RIP

Black 87 Starion ~ Mess SOLD!!!

Proud New 89 slightly Rusted Fiji Owner !!!




#12 Rob D

Rob D

    Newbie

  • Newbies
  • Pip
  • 6 posts
  • Location:Groton

Posted 17 October 2016 - 11:37 PM

Groton Mass.

#13 Zoggy87

Zoggy87

    Member

  • Members
  • PipPip
  • 387 posts
  • Location:USA

Posted 22 October 2016 - 10:43 PM

My car was running fine after my t3t4 conversion. Then I decided to install maf-t and it immediately stopped running correctly and would fall on its face if it even tried to boost. I thought there was no way it could be anything other than the maft and GM maf since it ran fine the day before. Long story short, I reverted back to stock to no avail. I rebuilt the throttle body and installed a fuel pressure gauge. Sure enough, 36 lbs at idle, but drops to under 10 lbs anytime secondary injector kicks on. Fuel filter and pump. I would suggest installing a gauge and testing pressure as well. There's a plug in the top hat of the throttle body that is 1/4" British standard pipe thread that you can remove and tap to 1/4" npt and install a 90* to 1/8" npt fitting for the gauge. That and having a wide band helps you tremendously in troubleshooting. P.s., This problem caused me to miss the national meet...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users