Jump to content



1986 ECU


  • Please log in to reply
8 replies to this topic

#1 stesir

stesir

    Established Member

  • Members
  • PipPipPip
  • 1,019 posts
  • Gender:Male
  • Location:Philadelphia, PA
  • Interests:I love YaBB 1G - SP1!
  • Model:Conquest

Posted 18 October 2018 - 07:17 AM

anyone have a known good 1?  Or 1 they know is good, they may not want to part with it that I can just borrow?  I'd return it and pay a fee even :)... I just have to eliminate this factor in trying to get a 1986 running right...Thanks Much.





#2 markhansenconquest

markhansenconquest

    Established Member

  • Members
  • PipPipPip
  • 3,300 posts
  • Gender:Male
  • Location:temecula,ca
  • Model:Conquest

Posted 18 October 2018 - 04:42 PM

I sold u 2 and they ran my 86 fine ???
it must be something else !!!!!!

Edited by markhansenconquest, 18 October 2018 - 04:43 PM.


#3 stesir

stesir

    Established Member

  • Members
  • PipPipPip
  • 1,019 posts
  • Gender:Male
  • Location:Philadelphia, PA
  • Interests:I love YaBB 1G - SP1!
  • Model:Conquest

Posted 20 October 2018 - 12:44 PM

This car is a 1986 Mitsubishi Starion intercooled turbo.  But I know the re-built motor is 1988.  I had done my best to get 1986 parts all on it .  The 86 ecu’s do not run the car, it just cranks , I had another 86 or 87 ecu ? and that 1 will start the car but stalls right out once you leave go of the key. I also have a 89 ecu and that 1 will start the car and rev it real high right away but have to get on the gas pedal to keep from stalling out which it’ll do...seems like we got a loose acc cable slack in it but am unsure about tps reset, not confident in that. I know where to find it ,have 3 years shop books but it’s just a matter of doing it right.
Thanks.

#4 Tim_C.

Tim_C.

    Addicted Starquester

  • Moderators
  • PipPipPipPipPip
  • 10,077 posts
  • Gender:Male
  • Location:Western Slope of Colorado
  • Interests:Serving Our Lord Jesus Christ!
  • Model:Conquest

Posted 05 November 2018 - 11:27 PM

Sounds like it could be a bad MAF to me.
'87TSi .510Roller Cam, JE Forged, TS Rings & plateau honed walls, lightened rods, race prepped crank, mains line honed, balanced, 17C, 3"EX, 2"HardPipes, AlFly, rrfpr, 88trans, 3.90's w/posi plate mods, polyBushings, STSprings, KYBStruts, Camber Plates, CustomAlternator
Traded for new set of tires for my wife's Buick: '87 TSI Gold that needs just about all steering and suspension parts replaced, injectors, a new transmission, clutch, and various electrical gremlins. New owner is a mechanic who is already driving it. I couldn't stand letting it sit any more!
'86 ESiR - OEM Roller Cam, Wiseco Forged 8:1 Pistons, Chad's equal length header, TEP T3/T4 turbo, ACT HD clutch, Fidanza Fly, custom 3" exhaust, 3 core oversized radiator, O-ringed block, AJUSA metal shim head gasket, Dawes Device boost controller
'85 Plymouth Conquest Auto , Wiseco 8:1, super light pins, shaved rods, hi-torque cam, 2.5 Exhaust
'84 Dodge Conquest Parts car
'83 Starion - Gutted stock exhaust with '87 TSi muffler, New engine with: BS Elim,forged Wisecos,balanced,Schneider274H,marnal w/oversized stainless valves
'83 Cannonball Run II Jackie Chan car, Basic ring and bearing job w/less than 6K original miles on body, steering, suspension, & rear end, Lightened stock fly, BS Elim, Walbro 255LPH FP, NEW Clearwater head with all new parts, intercooled, 14G turbo, 2750 car weight
'96 Mitsu Mirage w/rebuilt head. Gets 35+MPG.
'87 Dodge Ram50 4WD Rebuilt engine, fresh stock head, Weber carbed, BS elim. Runs great now!
'97 Buick Ultra (supercharged Park Avenue)

#5 croquest87

croquest87

    Established Member

  • Members
  • PipPipPip
  • 1,217 posts
  • Gender:Male
  • Location:willoughby
  • Interests:all things mechanical
  • Model:Conquest

Posted 06 November 2018 - 06:30 AM

I think you need to start tracing each wire and know what it does and controls as 86 is slightly different from 87-89 . It fires both injectors at the same time and uses MAP sensor and some form if IAT sensor along w MASS airflow sensor. Never had tried it but many people have run 86 without MASS airflow. My opinion on just plugging in 87-89 ecu w out knowing what controls what is a shot in the foot as circuits are most likely different. I would stick with 86 ECU and start using voltmeter on everything.Figure out how to test certain key components that make this thing run. Research test and know what does what and will have it running eventually. Sounds like lots of work but that's what it takes because you are working w out OBD2 to send you in right direction. Onother option is to sell all them ECU s and have Scott87 build you Megasquirt set up for TBI and be done w it. Unless you prefer original stuff which can be hard to troubleshoot w out lots of know how and major PITA. Just swapping parts and guessing cost you lots of money and most of the times will get you nowhere.

Edited by croquest87, 06 November 2018 - 06:38 AM.


#6 markhansenconquest

markhansenconquest

    Established Member

  • Members
  • PipPipPip
  • 3,300 posts
  • Gender:Male
  • Location:temecula,ca
  • Model:Conquest

Posted 06 November 2018 - 06:00 PM

^^^ I sold him a good 86 maf off my  86 W/B  ..are u sure u have a 86 TBI and not a 87-89 ??  86 has 1 plug and 87-89  has 2 plugs..........thats one of the thing I was fighting on mine .......do u have a 86 fuse link box by the battery ?? 86 and 87-89 are different   ... the fuse links control different things on 86 than 87-89..they look almost the same.... post a picture of your TBI...............and your ENG bay.................

Edited by markhansenconquest, 06 November 2018 - 06:01 PM.


#7 stesir

stesir

    Established Member

  • Members
  • PipPipPip
  • 1,019 posts
  • Gender:Male
  • Location:Philadelphia, PA
  • Interests:I love YaBB 1G - SP1!
  • Model:Conquest

Posted 25 November 2018 - 11:05 AM

I’ll do what you said...
I’ll have to email you the pics though.  Thanks.

#8 stesir

stesir

    Established Member

  • Members
  • PipPipPip
  • 1,019 posts
  • Gender:Male
  • Location:Philadelphia, PA
  • Interests:I love YaBB 1G - SP1!
  • Model:Conquest

Posted 06 December 2018 - 08:20 AM

I'm still looking for a known good '86 ECU...

#9 markhansenconquest

markhansenconquest

    Established Member

  • Members
  • PipPipPip
  • 3,300 posts
  • Gender:Male
  • Location:temecula,ca
  • Model:Conquest

Posted 06 December 2018 - 01:52 PM

send me  the pictures again... they got deleted...........OK




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users