Jump to content



86 ISC weird behavior


  • Please log in to reply
3 replies to this topic

#1 arbor

arbor

    Member

  • Members
  • PipPipPip
  • 37 posts
  • Location:north vancouver

Posted 19 March 2020 - 06:09 PM

So full disclosure I do not have the MAF on the car, I bought it this way and it runs really well without it. no other weird issues to report.

The only thing I can not seem to figure out is this weird cold start issue where the car will start and idle up to around 1k+ rpm and just stay there, it will never idle back down to were the ISC/tps was set at 850 give or take.
I have had the ISC apart cleaned the gunky old grease and cleaned the motor brushed and verified it works. The ISC checks out when following the service manual  tests.

I have reset the ISC multiple time and it always behaves the same way, cold start with just sit at 1k+ and stay there. the only way I can get it to idle back down to 850 ish is to turn the car off then turn the ignition on for 15 sec (let the ISC move) then start the car and then its normal for the entire time i'm driving the car.  

Has a new CTS install which ohms out correctly against the service manual at least at cold temps.
Throttle cable doesn't seem to be hanging the linkage up, so I am wondering if this is just the nature of the car with out the MAF.

Any one with an 86 chime in on this?





#2 tux

tux

    Established Member

  • Members
  • PipPipPip
  • 1,411 posts
  • Gender:Male
  • Location:new jersey
  • Model:Starion

Posted 23 March 2020 - 09:57 AM

Without MAF I would have to hold the gas to maintain idle.

I ended up tossing a 1g MAF in and its back to fine.

#3 arbor

arbor

    Member

  • Members
  • PipPipPip
  • 37 posts
  • Location:north vancouver

Posted 26 March 2020 - 04:19 PM

View Posttux, on 23 March 2020 - 09:57 AM, said:

Without MAF I would have to hold the gas to maintain idle.

I ended up tossing a 1g MAF in and its back to fine.

Is yours an 86? The 86 are very different in terms of the ECU setup compared to the later cars.

#4 tux

tux

    Established Member

  • Members
  • PipPipPip
  • 1,411 posts
  • Gender:Male
  • Location:new jersey
  • Model:Starion

Posted 26 March 2020 - 07:29 PM

View Postarbor, on 26 March 2020 - 04:19 PM, said:



Is yours an 86? The 86 are very different in terms of the ECU setup compared to the later cars.

Yep my 86.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users