Jump to content



Fix your temperamental (or broken) plastic knock box!


  • Please log in to reply
3 replies to this topic

#1 luckyboots

luckyboots

    Member

  • Members
  • PipPip
  • 163 posts
  • Gender:Male
  • Location:Tulsa, OK
  • Interests:my Conquest, computers, work and school
  • Model:Conquest

Posted 26 March 2007 - 02:21 AM

I heard alot of things about the plastic knock box having problems and dismissed them because I was not having the problem, until that day when my car died when I shut the hood. Then it wouldn't start, then it died at least 2 times a day until I finally got sick of it and formulated a plan. My plan (since I'm usually poor and impatient) involved fixing the knock box I had instead of getting a new one. I searched all over SQC for an account of someone cracking one of these things open and fixing the bad solder joints within, to no avail. I was ready to break some new ground and crack this thing, because if I didn't and my fix didn't work, chances would have been I would need a ride home from work that day.

I imagine this fix will only work if you have the common symptoms of a bad knock box (won't start unless you jiggle the plug, dies randomly, etc)

Tools needed:
Solder pen
Solder with flux built right in
Grinder or dremel and a good eye
Patience
Screwdriver
Solder wick or solder sucker (if you mess up)
Light so you can see what you're doing
Hot glue or silicone

Est. price for the average do-it-yourselfer - $0
Avg. time - 1 hour

(taken from an earlier post)
My car is dying all the time because of the stupid thing so I decided if it's just a bad solder joint what's the point of shelling out at least $100 for a new metal one if I can fix mine for free. (Thank my dad for this, he is religious about fixing bad solder joints in his profession)

I pulled it out and took the plastic side that looks glued on in to the grinder and ground off the edges (4 edges to the box, I ground off the 3 opposite of the connector edge, then just snapped the fourth edge off) that holds it on just enought to expose the circuit board and all of the solder joints. There are 8 larger joints on the side of the external connector and I believe those to be the culprit. Especially the one all the way to the left, as I saw some corrosion on the pin from arcing. I didn't want to take any chances so I just resoldered every single connection on that board. I realigned what was left of that plastic panel and hot glued it (only if you relocate your box! if you don't, USE HIGH TEMP SILICONE - HOT GLUE WILL NOT WORK UNDER YOUR HOOD). So far it has started up 30 or so times for about 3 days straight and hasn't had any of the symptoms since so I'm hoping this problem has been solved, at least for some time.

My next step is to extend all of the wires in that harness about 3 or 4 feet and run them through the firewall. I want to mount that box somewhere under dash where it's nowhere near as hot and the vibrations, moisture, oils and dirt shouldn't be as bad. I just finished doing this and it works like a charm. If you hold the box and let your car idle you can feel the relay clicking every once in awhile.

Tools needed:
Three 4ft lengths of 14ga shielded wire
Four 4ft lengths of 14ga stranded (not solid) wire
One 4ft length of 12ga stranded wire
Roll of 3M Super33 Electrical tape
Solder
Solder Gun
(2) Crimp on Ring terminals
Self tapping screws
Unibit and grommet (for hole in firewall)
4-5ft 3/4" Split loom
Zip ties
A good imagination

Est. Price - $20-$30
Est. Time - 1-3 hours






















Thanks for reading everybody and I hope this helps. I bet there are alot of broken boxes lying around waiting to be resurrected!

Eric G
1987 Black Conquest
KDM 3" Exhaust. Custom molded cup holder! Steel braided oil cooler lines from thetexan88.   1G MAS and HKS Airbox.   3" AHP.  Stage 2 Clutch.  240mm Flywheel.   JVE.   ABS Delete.   About 100lbs weight reduction so far.   GM 105 amp alternator. Eibach Pro Kit. MK1 Full Poly Bushing Kit. KYB GR2's. KDM OVCP. HKS BOV. MK1 Swaybar bushings, Axxis ULT pads, Slotted rotors, Braided brake lines, MK1 Airdam

Next up: 4G63T, W58, Billhousing, success





#2 Tim_C.

Tim_C.

    Addicted Starquester

  • Moderators
  • PipPipPipPipPip
  • 10,059 posts
  • Gender:Male
  • Location:Western Slope of Colorado
  • Interests:Serving Our Lord Jesus Christ!
  • Model:Conquest

Posted 02 April 2007 - 07:50 AM

It is easier to separate the entire plastic enclosure from the the metal back plate on the back side of the box. Then you can reassemble and seal it just like it was from the factory.

Problems with the knock box can be very mysterious. I "fixed" mine by unplugging one box, and plugging in another. Only to have that one go out in a month or so. Then I would plug the old one back in for another month. Took it apart and found no problems. Reflowing a good solder joint fixes nothing, but won't hurt as long as you do it correctly. You need to see evidence of the joint cracking, etc..., before you can safely say that reflowing it is what fixed it.

I found my problem was actually a bad secondary injector sticking open. I know, weird, but that is all I did to fix the knock box going out. Replacing the secondary injector. The fuel system was freaking out from too much fuel, and a failsafe ignition cut circuit was shutting off the knock box. That was the only way we could explain what was happening.
'87TSi .510Roller Cam, JE Forged, TS Rings & plateau honed walls, lightened rods, race prepped crank, mains line honed, balanced, 17C, 3"EX, 2"HardPipes, AlFly, rrfpr, 88trans, 3.90's w/posi plate mods, polyBushings, STSprings, KYBStruts, Camber Plates, CustomAlternator
Traded for new set of tires for my wife's Buick: '87 TSI Gold that needs just about all steering and suspension parts replaced, injectors, a new transmission, clutch, and various electrical gremlins. New owner is a mechanic who is already driving it. I couldn't stand letting it sit any more!
'86 ESiR - OEM Roller Cam, Wiseco Forged 8:1 Pistons, Chad's equal length header, TEP T3/T4 turbo, ACT HD clutch, Fidanza Fly, custom 3" exhaust, 3 core oversized radiator, O-ringed block, AJUSA metal shim head gasket, Dawes Device boost controller
'85 Plymouth Conquest Auto , Wiseco 8:1, super light pins, shaved rods, hi-torque cam, 2.5 Exhaust
'84 Dodge Conquest Parts car
'83 Starion - Gutted stock exhaust with '87 TSi muffler, New engine with: BS Elim,forged Wisecos,balanced,Schneider274H,marnal w/oversized stainless valves
'83 Cannonball Run II Jackie Chan car, Basic ring and bearing job w/less than 6K original miles on body, steering, suspension, & rear end, Lightened stock fly, BS Elim, Walbro 255LPH FP, NEW Clearwater head with all new parts, intercooled, 14G turbo, 2750 car weight
'96 Mitsu Mirage w/rebuilt head. Gets 35+MPG.
'87 Dodge Ram50 4WD Rebuilt engine, fresh stock head, Weber carbed, BS elim. Runs great now!
'97 Buick Ultra (supercharged Park Avenue)

#3 Chad

Chad

    noob

  • Moderators
  • PipPipPipPip
  • 9,111 posts
  • Gender:Male
  • Location:Lincoln City Oregon
  • Interests:Starquest Fanatic
  • Model:Conquest

Posted 02 April 2007 - 10:25 AM

the failed one I took appart had a broken (burnt) spider wire from the processor to the main board, it was unrepaireable.  

the broken/failed solder joint is most likely the fault in intermitant ignitors,  which accounts for probalby a good 80-% of those that need repair.  It if went out like a switch, it may be caused by what I found in mine.

Good info though, it's always better to try to fix them, they aren't worth anything broken anyway, so you have nothing to loose.

#4 macrophage

macrophage

    Established Member

  • Members
  • PipPipPip
  • 914 posts
  • Gender:Male
  • Location:9/11 NYC
  • Interests:starion, model railroading, inventing.
  • Model:Starion

Posted 07 April 2008 - 02:41 PM

Remember to keep your knock boxes grounded good. these things are like amplifiers, if current cant go to
ground then it will blow out.
Mine blew out when it wasnt grounded properly.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users