Jump to content



1989 Chrysler Conquest TSi


  • Please log in to reply
178 replies to this topic

#161 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 27 July 2017 - 09:07 PM

Big milestones today.  FINALLY got the 3" exhaust finished up, from the turbo to the tail.  Borla muffler sounds great.  Also go the Lamda gauge working, found a broken wire so it wouldn't read the sensor.  It's running great at idle but anything above that is super rich.  The FIC injectors I bought used from a member were dripping fuel so I installed an old set of factory injectors.  They are probably leaking pretty bad.  I need to purchase the AN fittings and injectors for the Low impedance injectors modified injector holder I bought.  That will probably correct my rich issue.  Then I can install the hard pipe kit with the MAF-T and really start tuning and driving the car.

Edited by mbruneaux, 29 July 2017 - 03:42 PM.

Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel





#162 importwarrior

importwarrior

    6 Quests and Counting......

  • Moderators
  • PipPipPipPipPip
  • 18,313 posts
  • Gender:Male
  • Location:Manassas VA
  • Interests:Boost = 2KWIK4U
    Starquests
  • Model:Conquest

Posted 29 July 2017 - 10:22 AM

Nice. Keep at it.

B-71 87 TSI ~ RIP

Black 87 Starion ~ Mess SOLD!!!

Proud New 89 slightly Rusted Fiji Owner !!!




#163 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 18 August 2017 - 12:27 PM

Finally got somewhere in the last few days.  
The 3” exhaust is in and working with the AEM AFM working correctly after finding a broken wire.  Started the car and it idled great at about 13.4 but when accelerating it went pig rich to 8 or 9.  Suspected the culprit to be the secondary injector, this being the third set of injectors I had tried, one set being FIC I believe. At least with the AFM I had some proof the issue was fuel.
I had purchased one of CHADs modified Injector mixers and finally bought the new injectors and AN hardware.  I purchased Fragola fittings because they are designed and manufactured here in Connecticut plus they were less than Aeroquip.  I couldn’t be happier with the product.  I’m still using the factory FPR since I have three spares.

Posted Image

Posted Image


Hooked it all up and car started great and after fixing a small fuel leak from a loose fitting took it for a blast.  It pulls hard!  I have 38 PSI at Idle. Of course I still have a few issues, the afr is reading super lean (17 to 18) when idling and deceleration but at open throttle the readings come down to 12 or 13.  I need to check the TPS calibration and make sure everything is tight but it RUNS!!!!
On deceleration the afr goes full lean and exhaust pops.

Edited by mbruneaux, 18 August 2017 - 12:29 PM.

Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#164 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 03 September 2017 - 09:30 PM

Installed the Spa Turbo AFPR and the AFR readings are 15 or 16 with a high idle of 1K or so.  Actually drove the car a little and it runs cool and pulls hard.  Verified temps with a laser temp gun.  I might actually have a running driving car although I think I need to lower the boost. It's nice and rich under boost though.

We tried to replace the oil filter adapter "o" rings but didn't have a socket big enough to unbolt it from the block.  I get to buy more tools!!

The AFR readings are very erratic which I guess is normal but it drives nice.  I will try and drive it more tomorrow but don't know if I want to have a tow truck driver sent out on Labor day....
Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#165 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 15 December 2017 - 05:13 PM

Was experiencing the oil bleed down issue and bought a known good pump from Drake.  Finally got it installed and it sounds much better, the oil pressure gauge (new sender) reads great but it did before also.  I will start it tomorrow to see if the pump fixed the issue.  Fun car in the snow with summer tires on!!
Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#166 importwarrior

importwarrior

    6 Quests and Counting......

  • Moderators
  • PipPipPipPipPip
  • 18,313 posts
  • Gender:Male
  • Location:Manassas VA
  • Interests:Boost = 2KWIK4U
    Starquests
  • Model:Conquest

Posted 17 December 2017 - 12:47 PM

Your brave.
Itís like you spray water at my car it wants to spin out. LoL

B-71 87 TSI ~ RIP

Black 87 Starion ~ Mess SOLD!!!

Proud New 89 slightly Rusted Fiji Owner !!!




#167 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 02 January 2018 - 08:21 PM

Bleed down issue has been largely corrected. The few times I drove it I've had this popping issue at around 2.5k or 3k.  I tested my vacuum advance and found the vacuum hose I had used for my vacuum advance was too big and loose!!  I thought I had replaced it with new silicone hose I had purchased but I hadn't. Vacuum advance is good , used a mity vac and it held solid. So basically I had a vacuum leak and a non functioning advance. It idles much better, no road test for a while because we have more snow on the way.



As is typical I had convinced myself this morning to sell it in the spring (again) but once I see it going down the street and hear that 3" Borla tractor the first thought in my mind is how cool it will be when it's done enough that I can drive it every day.

Edited by mbruneaux, 02 January 2018 - 08:23 PM.

Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#168 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 13 April 2018 - 10:33 AM

Installed the MAFT 2nd Gen and wouldn't start, checked everything thrice.  Reinstalled the original intake system hooked repaired the wire and still won't start.  Turns over but won't fire.  Has fuel pressure.  I'll be going through the manual to troubleshoot......
Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#169 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 17 September 2018 - 08:41 PM

Igniter is bad so I installed the 4 pin HEI and it ran great! Actually drove it for a while.  But now it starts and stalls.  The fuel gauge stays solid at 42psi but the A/F gauge goes totally lean and it dies.  I'm hearing all kinds of buzzing I'd never heard before.  Giving it throttle makes no difference.  Will probably start with the Idle reset procedure....

New Injector clips
New GM low impedance injectors
Manual FPR
Generic 4 PIN ignition module - feels kind of warm
Miata TPS properly adjusted to .5 V
Vacuum lines replaced

Edited by mbruneaux, 17 September 2018 - 08:44 PM.

Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#170 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 25 September 2019 - 07:39 AM

No progress BUT I ORDERED MORE PARTS!!!!!!!!
Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#171 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 25 October 2019 - 06:53 PM

Barn Find!!!! Pulled it out of the barn, bought a new battery for it and tried to start it.  Same problem as before...  Starts up rough but then stalls.  Fuel pressure stays at 42 PSI.  It has the 4 wire GM ignition module that worked great for a while and then it started doing this.  It also has the modified throttle body using Precision Turbo Fuel injectors.  Even swapped them to make sure they weren't crossed. Next step is resetting the ICS I believe....

Edited by mbruneaux, 25 October 2019 - 07:57 PM.

Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#172 jinx

jinx

    Established Member

  • Members
  • PipPipPip
  • 1,965 posts
  • Interests:I love YaBB 1G - SP1!

Posted 25 October 2019 - 07:58 PM

starts & stalls - no vacuum leaks/hose blowing off ?
HEI module should be mounted to heatsink of some sort or chunk of metal so it can dissapte heat
Hope it didn't burn up.  I think one wire pulse coil neg & triggers ecu to fire injectors

#173 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 26 October 2019 - 05:24 AM

View Postjinx, on 25 October 2019 - 07:58 PM, said:

starts & stalls - no vacuum leaks/hose blowing off ?
HEI module should be mounted to heatsink of some sort or chunk of metal so it can dissapte heat
Hope it didn't burn up.  I think one wire pulse coil neg & triggers ecu to fire injectors

Its not a typical starts and stalls, it will run for about 5 or 6 seconds and then stall.  I've already tried another module but will look again for a vacuum leak.
Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#174 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 28 October 2019 - 06:33 PM

It was the MAS, I had a spare one from Graham (only first name needed) and it started and idled pretty well!!  Not to start making it drive able.
Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#175 jinx

jinx

    Established Member

  • Members
  • PipPipPip
  • 1,965 posts
  • Interests:I love YaBB 1G - SP1!

Posted 29 October 2019 - 06:11 AM

good to post a follow up. Oem MAFS fairly reliable after all these years
Lots run Translators & 1st gen DSM MAFS, so stock ones should still be around.... what didn't get tossed

#176 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 29 October 2019 - 12:47 PM

Before this issue I had installed a MAFT but couldn't get it to start.  I need to review my wiring, which I've done 100 times, and try again.  The wiring is not that complicated but I'm missing something or I could have a bad MAFT which I bought second hand.

Edited by mbruneaux, 29 October 2019 - 12:53 PM.

Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#177 Ressurect1on

Ressurect1on

    Member

  • Members
  • PipPipPip
  • 90 posts
  • Gender:Male
  • Location:KC, MO
  • Model:Conquest

Posted 05 November 2019 - 08:43 PM

Where did you get the magna roller cam and rockers from?

#178 mbruneaux

mbruneaux

    Established Member

  • Members
  • PipPipPip
  • 1,474 posts
  • Gender:Male
  • Location:Canterbury, CT
  • Interests:Family, Strength Sports, Starquests, and Brewing Belgian Ale.
  • Model:Conquest

Posted 05 November 2019 - 10:53 PM

View PostRessurect1on, on 05 November 2019 - 08:43 PM, said:

Where did you get the magna roller cam and rockers from?

I don't have those, wrong thread?
Canterbury, CT
1989 Chrysler Conquest TSi (Project Race Car) Build thread http://www.starquest...opic=147910&hl=
2001 BMW 740iL - My Daily
2003 Chevrolet Suburban 2500 8.1  To tow the two hay burners
2010 Charger R/T  daily driver

Second place is S*** place , eh.  - Stéphane Peterhansel

#179 Ressurect1on

Ressurect1on

    Member

  • Members
  • PipPipPip
  • 90 posts
  • Gender:Male
  • Location:KC, MO
  • Model:Conquest

Posted 06 November 2019 - 06:11 PM

Maybe, as cruising the forum for a while, and may have crossed my threads, thought you where running a roller setup.

interestingly, I found a 94 magna getting parted in aussie land, but he wouldn't ship to states. :(




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users