Jump to content



FUEL SYSTEM REBUILD/PUMPS/TANK/FILTERS


  • Please log in to reply
64 replies to this topic

#41 albanyGA87TSI

albanyGA87TSI

    Member

  • Members
  • PipPipPip
  • 149 posts
  • Location:Leesburg GA

Posted 25 February 2005 - 10:13 AM

Howdy!
I am replacing my stock replacement pump with the Walbro because the Advanceauto pump was real erratic in its operation...   not only was it noisy then quiet but it would push fuel at different rates into my gas can... so I got my money back. ;D

Conical filter was in place and clean, along with new in tank and high pressure

Before returning it I checked voltage to the pump and it was 9.6v or so ...what should the voltage be?

On the wire to fuel pump connector there is a black box inline before the pump... what is it?
what does it do?
Do I need it?

Many Much Thanks

Bill
87 Conquest





#42 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 26 February 2005 - 12:20 PM

Bill, Take a battery voltage reading with the engine off. Now start the engine and take another reading. Do this right at the battery. It should have about 12.2 to 12.6 with the engine off. 14.2 to 14.6 with the engine running. Now place a jumper wire to the FUEL PUMP TEST PORT (above the air cleaner, black wire/white strip) This SHOULD provide NEARLY full battery currant to the pump. If the pump changes it's tone (sounds better) You may have some resistance along the way to the pump. (ANY CONNECTOR) You have MANY miles on your car and it might need a new RELAY. You never said WHERE EXACTY you tested your voltage.

The "black box" in the fuel pump harness is a RELUCTOR. It's a noise reduction device for the radio. They generally don't have problems. Yes it could be eliminated. But you can easily test voltage on BOTH SIDES OF IT.

If the inlet of ANY fuel pump is not the EXACT SAME DIMENSIONS AS THE FACTORY PUMP, NEVER INSTALL THE CONICAL FILTER!!!!! Most people don't stop to think HOW that filter works. It snaps INTO the fuel pump inlet nipple. Therefore it must have CLEARANCE around the outside of the filter. It you force it into an opening that is TOO SMALL, the fuel has no place to go AROUND the screen. So you just put a CHOKE-HOLD on the fuel supply. I tested several aftermarket pumps for proper FIT. In my opinion, none of them had enough clearance to use that filter. Most inlet nipples are a SEPERATE SOLID BRASS NIPPLE WITH VERY THICH WALLS. Look at your stock pump.........it's very THIN and part of the housing. Worse yet, you will probably FRACTURE THE NYLON HOUSING OF THE FILTER. Guess what happens to the small particles that will flack off? I have always said...............don't use a OLD FILTER AGAIN. But some guys clean them and stick them and FORCE them back into a nipple that is TOO SMALL. THAT FILTER SHOULD NOT BE IN THE HOSE WHEN YOU INSTALL IT!!!

I'm no typing wiz and I have never offerd the EXACT WAY the conical filter works. If I say don't use it............take my word for it. I spent HOURS coming up with a replacement filter because the conical has been deleted. I even showed you how to EXACTLY place the hose clamps to it can be removed from the hatch.

#43 albanyGA87TSI

albanyGA87TSI

    Member

  • Members
  • PipPipPip
  • 149 posts
  • Location:Leesburg GA

Posted 26 February 2005 - 01:08 PM

Hey Professor,

Couldnt care less how good or bad you type... just keep giving the info!!!!

I checked the voltage at the pump... and at the connector for the pump.  I will spend some time today looking over the wiring diagrams and check my relay and connections and test voltage at each one.  

Conical filter was an ok fit  in the other stock pump but of course is eliminated with the Walbro.  

I am copying your filter design so....once again... thanks for the great info!!

Bill
87 Conquest

#44 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 26 February 2005 - 11:38 PM

See FP-1 thru FP-38 on my website. Have'nt added text...........yet. wink.gif

#45 albanyGA87TSI

albanyGA87TSI

    Member

  • Members
  • PipPipPip
  • 149 posts
  • Location:Leesburg GA

Posted 01 March 2005 - 12:57 PM

the fuel pump connector to the pump was broken and has been replaced... now have full  battery voltage to pump.

Installed and cruising  thanks Again!!
87 Conquest

#46 MidMoTSI

MidMoTSI

    Established Member

  • Members
  • PipPipPip
  • 561 posts
  • Gender:Male
  • Location:Jefferson City, MO
  • Interests:Keep the turbo spooled!
  • Model:Conquest

Posted 04 March 2005 - 08:13 AM

I ordered the GSL392 and installation kit from the following link.  as Bill S said, $127.93 with free shipping, promo code: starquest

http://www.autoperformanceengineering.com/

#47 albanyGA87TSI

albanyGA87TSI

    Member

  • Members
  • PipPipPip
  • 149 posts
  • Location:Leesburg GA

Posted 04 March 2005 - 10:05 AM

You might find this amusing... maybe not... either way, heres my DUH of the day....

I got the pump installed and tested then hit the road...

I noticed a loud vibration that occured intermittantly,  :o either in the throttle or off it... ???
I thought I had a bad pump because it sounded like a cavitation noise... so i dropped the tank and tested the pump...........no noise. :-/

Put it all back together again ... but left the trunk dismantled and hit the road .... no noise ;D  went home put covers on the fuel level and pump access and a few hours later the kids and I hit the road... and dang-it there was the vibration again  :'(

It turned out to be the cover for the Fuel level connection   :smile.gif... the sticky stuff was dry and it stuck a little when i placed it but vibrated like he!! once driving

So.... DUH!!!! :smile.gif :smile.gif
87 Conquest

#48 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 13 March 2005 - 11:08 PM

QUOTE
I ordered the GSL392 and installation kit from the following link.  as Bill S said, $127.93 with free shipping, promo code: starquest

http://www.autoperformanceengineering.com/

Ok guys...............I KNOW. I'm the one who set that purchase price up with Ron. ;D The pics are nice............but you gotta do a little reading. ;D

#49 Qst4Speed

Qst4Speed

    Member

  • Members
  • PipPipPip
  • 332 posts
  • Gender:Male
  • Location:Ocala, FL
  • Model:Conquest

Posted 22 March 2005 - 08:07 PM

Ok, I must be an idiot but I went to that link and I cannot find the pump and kit listed for our cars. Is it listed as something else. There is not a search feature for their site either. Can anyone help me out here? Thanks.

Rick

#50 BuGG

BuGG

    Established Member

  • Members
  • PipPipPip
  • 1,940 posts
  • Gender:Male
  • Location:Pennsylvania
  • Interests:Starquests forever!
  • Model:Conquest

Posted 23 March 2005 - 01:26 PM

On the right look under fuel pumps.  Then click on external.  Its under there.  Personaly I would just cal them to make sure you get the install kit for our car.  


BuGG
Posted Image

#51 wolfsquest

wolfsquest

    Established Member

  • Members
  • PipPipPip
  • 633 posts
  • Gender:Male
  • Location:Augusta, Georgia
  • Interests:Gun control means using BOTH hands for target aquisition!!!
  • Model:Conquest

Posted 23 March 2005 - 10:09 PM

NOT trying yo be a smart a--, or anything but has anyone checked Tylerquest's thread in G/P, lately?  Might save you a couple of $$!

#52 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 25 March 2005 - 07:38 PM

First reply was modified and there are more install tips at the secound addy below. wink.gif

#53 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 25 March 2005 - 08:21 PM

QUOTE
NOT trying yo be a smart a--, or anything but has anyone checked Tylerquest's thread in G/P, lately?  Might save you a couple of $$!


Might not be what you wanted in the first place. But I can see as time has passed they are beginning to figure that out. Anybody else want to RE-INVENT THE WHEEL? That is the E8000 pump they are chasing. Common replacement STOCK pump. ;D

I give this site alot of good info.............but it ain't NOTHING compared to what I post on my forum at Trance's. wink.gif

#54 by_reQUEST

by_reQUEST

    Member

  • Members
  • PipPipPip
  • 236 posts
  • Location:Atlanta GA
  • Interests:Keep the turbo spooled!

Posted 26 March 2005 - 08:20 PM

I am assuming this si the 255lph pump y ou installed correct?

#55 wolfsquest

wolfsquest

    Established Member

  • Members
  • PipPipPip
  • 633 posts
  • Gender:Male
  • Location:Augusta, Georgia
  • Interests:Gun control means using BOTH hands for target aquisition!!!
  • Model:Conquest

Posted 26 March 2005 - 09:05 PM

Yep!, gsl 392.

#56 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 26 March 2005 - 11:08 PM

Wolf, do you have the phone number for the Napa you got the Walbro from?

#57 JustPaus_88TSi

JustPaus_88TSi

    This is my forest, and I am not afraid.

  • Members
  • PipPipPipPipPip
  • 13,960 posts
  • Gender:Male
  • Location:Gilbert, Arizona
  • Model:Conquest

Posted 26 March 2005 - 11:16 PM

Just a quick check..

There's 3 Napa's in Augusta..

1. (706) 722-7077... 304 13th St

2. (706) 724-4735... 1337 Reynolds St

3. (706) 863-1181... 3414 Washington Rd
Posted Image
88TSi-S16G~19x8.5's/19x10.5's~Anti-M-Power~S&M~FIP TBpro2R~E46 projector HID's/Fogs
2001 IS300-GTE swap~T04E 60-1 Garrett hifi~18" Volk CE28N~Tein Comfort Sport coilovers~TurboEast~PFS~Apex-I~Greddy~Blitz
2005 LS430-Staggered 20" Maya/Trafficstar DTS'~14k/12k Extreme Drop BC Coilovers~KYOEI-USA Representin...Bippu Status.

#58 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 26 March 2005 - 11:25 PM

Computer geek. :smile.gif Ok, wise guy...........who are the managers? tongue.gif

#59 JustPaus_88TSi

JustPaus_88TSi

    This is my forest, and I am not afraid.

  • Members
  • PipPipPipPipPip
  • 13,960 posts
  • Gender:Male
  • Location:Gilbert, Arizona
  • Model:Conquest

Posted 26 March 2005 - 11:32 PM

Strangely enough, the managers for all three are called.. "The manager".. LOL wink.gif ;D
Posted Image
88TSi-S16G~19x8.5's/19x10.5's~Anti-M-Power~S&M~FIP TBpro2R~E46 projector HID's/Fogs
2001 IS300-GTE swap~T04E 60-1 Garrett hifi~18" Volk CE28N~Tein Comfort Sport coilovers~TurboEast~PFS~Apex-I~Greddy~Blitz
2005 LS430-Staggered 20" Maya/Trafficstar DTS'~14k/12k Extreme Drop BC Coilovers~KYOEI-USA Representin...Bippu Status.

#60 Professor Quest

Professor Quest

    Advanced Member

  • Members
  • PipPipPipPip
  • 9,987 posts
  • Location:Albuquerque, NM.
  • Interests:Damn Things TurboCharged!

Posted 26 March 2005 - 11:36 PM

LOL! ;D Should have known that. LOL! ;D That's ok. I'll just ask for the commercial desk and have them open every box on both part numbers and have them describe the pump.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users