Jump to content



Setting Mazda TPS


  • Please log in to reply
17 replies to this topic

#1 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 22 February 2019 - 05:45 PM

I finally broke down and ordered the conversion kit and received it yesterday. I put the plate on and spiced the wires last night but it got late before I could finish. I finished it up this evening and went to try to set it but I'm having a issue here. I set my Multimeter like normal on 20 Dc volts. I hooked it up to the white/green wire as Hot and Black/green wire for ground. I turn it completely CCW and then turn it clock wise to get to .50volts. I can get it set there and tighten it down and still show .50volts but when I open the throttle wide open to see the volts I'm only getting 4.2, and when I release the throttle and it's fully closed it reads 2.1 volts. WHat am I doing wrong here??
Another thing, I can turn the car on and the throttle will read 40% on the SAFC.. WHen I had the original TPS in it read throttle correct...0% with the key on. Please help !!
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !





#2 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 23 February 2019 - 06:05 PM

Update: I gave it another try today. I set everything according to the writeup on here. I can set the TPS to .50volts and open the throttle and let it go and it shows 1.2 volts at the TPS. I reset the tps to .50 volts and hit the throttle and let off and it will show 1.4 volts on the TPS. Is this a sign pf a bad TPS or something else.
I have all new shaft seals, cleaned everything, ISC zips, set the idle to 800, and plugged the ISC back in. Nothing helps...I am completely lost here
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#3 rcm

rcm

    rcm

  • Members
  • PipPipPip
  • 2,323 posts
  • Gender:Male
  • Location:Stephenville Texas
  • Interests:Keep the turbo spooled!
    Motorcycles,dirt bikes,Old school
    muscle cars.
  • Model:Starion

Posted 23 February 2019 - 11:13 PM

Make sure.you have Tps stabbed in the throttle shaft plastic U.You have to pinch the Mazda lever a little to fit correctly on the original lever.

#4 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 23 February 2019 - 11:28 PM

I went back and done that today, and it didn't help with the setting staying at .50volts or with the throttle% showing so high with the throttle closed
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#5 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 24 February 2019 - 09:11 AM

I searched more last night and this morning and found something out that I had completely missed or overlooked.
It says when doing the reset to unplug the ISC which will have 3 wires on the ECM side and the MPS 4 wires on the ECM side.
The reset procedure says to unplug the rear most plug....you have the TPS plug, the ISC plug and then a plug that's mounted at an angle that has 3 solid wire colors coming out on the motor side. I think I have been unplugging the wrong one. Is the ISC plug the one thats mounted at an angle or the plug that's next to the TPS bracket
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#6 rcm

rcm

    rcm

  • Members
  • PipPipPip
  • 2,323 posts
  • Gender:Male
  • Location:Stephenville Texas
  • Interests:Keep the turbo spooled!
    Motorcycles,dirt bikes,Old school
    muscle cars.
  • Model:Starion

Posted 24 February 2019 - 12:05 PM

Are you checking the voltage on the plug next to the tps to make sure it is reading .92 volts?

#7 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 24 February 2019 - 12:19 PM

If you are talking about the one that is mounted at an angle with 4 wires on the ecm side and 3 on the motor side then yes, I have tested it. It came out to .89
THat's with the motor being cold, I don't know if it makes a difference or not

Edited by 81zfan, 24 February 2019 - 12:20 PM.

88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#8 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 24 February 2019 - 12:57 PM

Ok, I went back out, got the motor hot and then tested it. It was .92
I unplugged the correct plug in this time, did the procedure, and set the TPS to .50volts.
Tightened the cable and everything and plugged ISc back in and started it.
I now holds constant 875RPM's and the % on the SAFC is showing correct now. I have no clue what was throwing it all off,but it seems to be set right now and everything is as the Manual calls for.
I wish I could know what was causing it to read so crazy yesterday when trying to set it, but at least it seems to be set now.. FIngers crossed!
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#9 importwarrior

importwarrior

    6 Quests and Counting......

  • Moderators
  • PipPipPipPipPip
  • 18,412 posts
  • Gender:Male
  • Location:Manassas VA
  • Interests:Boost = 2KWIK4U
    Starquests
  • Model:Conquest

Posted 24 February 2019 - 01:59 PM

Glad you got it fixed. Had similar issue when installing one also.

B-71 87 TSI ~ RIP

Black 87 Starion ~ Mess SOLD!!!

Proud New 89 slightly Rusted Fiji Owner !!!




#10 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 24 February 2019 - 02:43 PM

I can't not figure out what was throwing it off so bad. I never took if back or anything, just adjusted it, and set everything like it supposed to be. I just hope it's right now
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#11 rcm

rcm

    rcm

  • Members
  • PipPipPip
  • 2,323 posts
  • Gender:Male
  • Location:Stephenville Texas
  • Interests:Keep the turbo spooled!
    Motorcycles,dirt bikes,Old school
    muscle cars.
  • Model:Starion

Posted 24 February 2019 - 09:31 PM

Everything has to read correctly on warmed temp engine.And correct isc plug disconnect.Sometimes you have to do it two or three times to get dialed in.

#12 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 24 February 2019 - 09:43 PM

I hadn't worked on the car in years and had forgotten how touchy the Tps was when setting it. I had to read and re-read the procedure to get it set right. I appreciate all the help as I was frustrated and had to take a break. The SAFC is reading right now and everything is set like it should be
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#13 Phantom

Phantom

    Member

  • Members
  • PipPipPip
  • 136 posts
  • Gender:Male
  • Location:Memphis
  • Model:Conquest

Posted 03 March 2019 - 08:23 AM

Which Masada TPS are you guys using with the kit?

#14 81zfan

81zfan

    Established Member

  • Members
  • PipPipPip
  • 974 posts
  • Gender:Male
  • Location:KY
  • Interests:Wrenching,Fishing,Bicycling, and collecting old school vinyl!!
  • Model:Conquest

Posted 05 March 2019 - 08:43 AM

I'm thinking it's early to mid 2000's mazda protege.
88 conquest, .30 over block,Bs eliminated, M28 head ,17c turbo,Ottowerks shifter bushing, Lower Shores Braided lines and TB parts, Boostinmini TPS conversion kit,Optional Methanol Kit "when hooked up",Custom 2.5 Intercooler Piping,3 inch Downpipe, Gasket Ported Intake and Exhaust Manifold, Manual steering conversion,ACT HD clutch, Ebay knock off GReedy BOV,put car on a diet "lost between 590-620 lbs", Super AFC, AEM wideband, Glowshift Boost,Fuel Pressure, and Coolant Temp gauges, ARP Head and Rod bolts/Studs, Walbro 255.... In the process of adding more !

#15 damageinc86

damageinc86

    Member

  • Members
  • PipPipPip
  • 80 posts
  • Location:Oregon

Posted 03 January 2020 - 02:00 AM

Man, It would be nice to have a video tutorial of this.  I just got that kit as well, and i'm scared now lol.  I'm coming from old school carb'd stuff, so I'm not privy to even this old school TB injection stuff.  I gave the manual a once over, and I was confused right away.  Maybe I just have to really study it and take my time.

#16 Preludedude

Preludedude

    Established Member

  • Members
  • PipPipPip
  • 3,782 posts
  • Gender:Male
  • Location:Spartanburg, SC
  • Model:Conquest

Posted 03 January 2020 - 06:35 AM

The following procedure must be followed to the letter for best results.
01 - Engine must be at operating temp.
02 - After engine is warmed-up, turn it off.
03 - Turn key to the ignition on position.
04 - Connect digital voltmeter to #2 and #3 terminals on TPS sensor.
05 - Turn TPS all the way counterclockwise and snug bolts.
06 - Disconnect ISC motor connector next to firewall and wait 10 seconds.
07 - Turn TPS clockwise slowly to set voltage.
08 - Set voltage to 0.48 - 0.52 (optimal = 0.50).
09 - Tighten TPS bolts without changing setting achieved in step #08.
10 - Depress accelerator fully - meter will show up to 5.0V. This value is directly affected by the setting obtained in step #08.
11 - Loosen accelerator cable.
12 - Start engine.
13 - Set idle speed to 750 RPM's.
14 - Shut off engine.
15 - Tighten accelerator cable - 1mm free play.
16 - Plug ISC motor connector.
17 - Turn ignition to the on position for 10 seconds.
18 - Shut ignition off.
19 - Start engine.
20 - Idle will go up slightly (100 - 150 RPM's - this is normal).
21 - ISC and TPS are now set.
Note: Be aware that the ignition is turned on in step #03 and is kept "on", until step #14.

#17 TroyStarion

TroyStarion

    Member

  • Members
  • PipPipPip
  • 136 posts
  • Gender:Male
  • Location:CT
  • Interests:Old race cars and classic rock
  • Model:Starion

Posted 25 August 2021 - 04:16 PM

View PostPreludedude, on 03 January 2020 - 06:35 AM, said:

The following procedure must be followed to the letter for best results.
01 - Engine must be at operating temp.
02 - After engine is warmed-up, turn it off.
03 - Turn key to the ignition on position.
04 - Connect digital voltmeter to #2 and #3 terminals on TPS sensor.
05 - Turn TPS all the way counterclockwise and snug bolts.
06 - Disconnect ISC motor connector next to firewall and wait 10 seconds.
07 - Turn TPS clockwise slowly to set voltage.
08 - Set voltage to 0.48 - 0.52 (optimal = 0.50).
09 - Tighten TPS bolts without changing setting achieved in step #08.
10 - Depress accelerator fully - meter will show up to 5.0V. This value is directly affected by the setting obtained in step #08.
11 - Loosen accelerator cable.
12 - Start engine.
13 - Set idle speed to 750 RPM's.
14 - Shut off engine.
15 - Tighten accelerator cable - 1mm free play.
16 - Plug ISC motor connector.
17 - Turn ignition to the on position for 10 seconds.
18 - Shut ignition off.
19 - Start engine.
20 - Idle will go up slightly (100 - 150 RPM's - this is normal).
21 - ISC and TPS are now set.
Note: Be aware that the ignition is turned on in step #03 and is kept "on", until step #14.

Hi, I am having a bit of trouble figuring out what you mean with step 10,

"10 - Depress accelerator fully - meter will show up to 5.0V. This value is directly affected by the setting obtained in step #08."

Do you mean that I pull the linkage, opening up the TB fully? Or do I release the linkage, closing the TB fully, and if in this case, at which step should I open the TB?

Thanks

87' Sarajevo White ESi-R- Daily driver for the summer
87' Serbia Black ESi-R- SOLD

#18 Evoz17

Evoz17

    Member

  • Members
  • PipPipPip
  • 198 posts
  • Gender:Male
  • Location:Washington
  • Interests:Mitsubishi's, soccer, life
  • Model:Starion

Posted 26 August 2021 - 09:02 AM

You dont mess with the linkage till after step 10. At step 10 get in your car and press the accelerator pedal fully, your meter should now read 5v dc at wide open throttle.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users